Wanhao i3 connection issues / stuck at print start


#1

Hello,
after a few months has passed that my printer has stopped working with Octoprint, i want to share my solution to this.
At the beginning i started with Octoprint 1.3.6 and had no issues with this setup. After updating to 1.3.7 I got always communication issues reported - I downgraded to 1.3.6 but this was also not working afterwards ( i thought the update caused this - but it seems not).
With the updates 1.3.8 and 1.3.9 it was again not working. I also tried to changed the settings as mentioned in this topic OctoPrint 1.3.7/1.3.8 is stuck in "Pausing" or "Cancelling" without any proper working results ( only in 1.3.8 it sometimes started to print ).
In between I had to print with the SD card directly inserted in the printer :face_with_symbols_over_mouth: .

The problem was:
Printer heated up bed and nozzle, and after positioning X,Y,Z to home position it stuck.
In the terminal I got frequently connection issues ( during heating up ) and also format errors reported (when it should start the print ).

The solution was:
I changed in the printer general settings the connection speed to 9600 Baud and also in Octoprint, since then its working.

:sunglasses:


#2

Awe man, to me this means that you need to replace your serial cable with one that's internally shielded or that has ferrite beads on it. Trust me.


#3

Hi, thank you for your input, but several cables had no impact on this issue, acutally a ferrite wire is in use.


#4

Think about it: 9600 baud. That was popular back in the days of AOL. Something is wrong with your serial connection.

Okay, so let's assume that the cheap UART is now in use rather then the good one.

Turn off Bluetooth
Disable serial-over-terminal in the raspi-config settings