Octoprint not sending G2/G3


#1

Hi,

I'm using Gcode that has G2/G3 (arcs) in it, but Octoprint seems not to send them.

If I send them via Terminal it works an Marlin interprets it right, If they are in he gcode they are just ignored.

Marlin 2.0.x
OctoPrint 1.3.1 rc3
tevo tarantula (mks 1.3 board)

example:

M107 S0

G90
G21
G1 F1000
G1  X105.0781 Y170.2207
G4 P0 
M106 S255
G4 P0
G1 F300.000000
G3 X55.6406 Y149.9811 I0. J-70.4982
G3 X35.3984 Y101.6758 I47.5162 J-48.3053
G3 X55.6404 Y53.3693 I67.7616 J0.
G3 X105.0781 Y33.1289 I49.4377 J50.2563
G3 X154.5159 Y53.3693 I-0. J70.4968
G3 X174.7578 Y101.6758 I-47.5196 J48.3065
G3 X154.5157 Y149.9811 I-67.7583 J0.
G3 X105.0781 Y170.2207 I-49.4375 J-50.2586
G1  X105.0781 Y170.2207
G4 P0 
M107 S0
G1 F1000
G1  X105.0781 Y169.957
G4 P0 
M106 S255

G1 X0 Y0

and octoprint just sends:

Changing monitoring state from "Operational" to "Printing"
Send: N0 M110 N0*125
Recv: ok
Send: N1 M107 S0*103
Recv: ok
Send: N2 G90*18
Recv: ok
Send: N3 G21*25
Recv: echo:Unknown command: "G21"
Recv: ok
Send: N4 G1 F1000*75
Recv: ok
Send: N5 G1  X105.0781 Y170.2207*7
Recv: ok
Send: N6 G4 P0*107
Recv:  T:-15.00 /0.00 B:17.73 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:18.63 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:18.95 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:20.47 /0.00 @:0 B@:0
Recv: ok
Send: N7 M106 S255*98
Recv: ok
Send: N8 G4 P0*101
Recv: ok
Send: N9 G1 F300.000000*90
Recv: ok
Send: N10 G1  X105.0781 Y170.2207*51
Recv: ok
Send: N11 G4 P0*93
Recv: ok
Send: N12 M107 S0*85
Recv: ok
Send: N13 G1 F1000*125
Recv: ok
Send: N14 G1  X105.0781 Y169.957*3
Recv: ok
Send: N15 G4 P0*89
Recv: ok
Send: N16 M106 S255*82
Recv: ok
Send: N17 G1 X0 Y0*31
Recv: ok
Changing monitoring state from "Printing" to "Finishing"
Send: N18 M400*30
Recv:  T:-15.00 /0.00 B:19.57 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:18.28 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:19.30 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:18.52 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:18.95 /0.00 @:0 B@:0
Recv:  T:-15.00 /0.00 B:18.95 /0.00 @:0 B@:0
Recv: ok
Changing monitoring state from "Finishing" to "Operational"

#2

You believe that G2 is being blocked by OctoPrint but I'm seeing a G21 command being ignored by your firmware.

But yes, the G3 commands appear to be ignored by OctoPrint.

I think the first thing to check would be both the printer profile settings for both OctoPrint and your slicer. For OctoPrint, check the flavor of firmware.


#3

Also test if the issue persist in safe mode.


#4

you are right - issue is gone in safe mode! So seems a plugin is filtering it out?


#5

the plugin exclude region caused the problem! good idea to try without plugins.


#6

And now you know why there is a safe mode :wink:


#7

So... if you had asked the Exclude Region plugin to not include that area, then this would be user error, methinks.

If you hadn't asked Exclude Region to do anything then please follow-up with the plugin author on his/her repository's Issue page. Thanks.