Octolapse crashes long prints


#1

I have seen some similar posts on here but they all seem to have been resolved and I am still experiencing this issue. I am running Octopi 0.15.1 and even upgraded Octolapse to the latest stable release just the other day. Settings were 15 FPS and the pics were to be taken every 0.2 mm layer change. Slicer I am using is the latest Slic3r PE using Chris W's pretty PLA profile printing 3D Solutech PLA. The print was to be around 8 hrs this time and at about 75-85%, it just stopped. Came in to find the print head and bed still hot, but Octopi was not connected and printer had to be restarted. I disabled octolapse and the print went thru just fine - absolutely no issues. Octolapse on anything less than 5 hours seems to have no issues - anything longer and it is iffy at best whether it will work. Is there a way to have it print from the SD card instead of thru Octoprint and still do Timelapse to ease the IO strain maybe? Or is it an issue with my settings and for longer prints I need to select the every 2 minutes or something option instead of the layer change? Pretty new to this whole 3D printing and RPi thing, so any suggestions are welcome!


#2

Hi @Travis_Chaney! Maybe you could try this again (if you're willing to lose a print), but using the 'Full Diagnostic - Live Print ' debug profile? Then can you download plugin_octolapse.log (available in OctoPrint settings->Logs) and create an issue on my github page here? A serial log would also be very helpful (must be enabled before your print starts). The settings.json (OctoPrint Settings->Octolapse->Download Settings) file would also be nice, as well as the gcode file. Basically everything it would take to recreate the issue, and every little bit helps!

Unfortunately these kinds of issues are very difficult to debug, and I need lots of info (printer type, etc) to figure it out. Thanks for your post!


#3

So i updated my firmware for the printer, rebooted everything, went thru and made sure the new Octolapse settings matched my slicer settings and then started a new 3 hr print. Same result- just stopped printing. Went to get the log files only to realize I didn’t have it setup to capture the logs for Octolapse OR Octoprint. So I am calling it quits today, and I will try again tomorrow. I made sure everything was setup to log now. My concern is that When it stopped, I had to reboot the pi before i could reconnect- will that prevent it from saving the log files?


#4

If OctoPrint itself crashed then it probably logged right up until its death, for what it's worth.


#5

Can you let me know what version of OctoPrint you are using? Also, your log files should be just fine, so double check OctoPrint Settings->Logs and see if you can download octoprint.log and plugin_octolapse.log and post them somewhere so that I can take a look. Also, please send me a copy of your settings.json (mentioned in my previous post) and your gcode file so that I can run some tests.


#6

So I was finally able to get some time to go thru and make sure everything was set up correctly and run the same exact GCODE using the test setting. And of course it worked without any issues. I also remembered to go in and change everything I could find to save a log file so I have those I can attach - I could not however, figure out how to get the JSON file? I guess I will try to run it again with just changing the octolapse to not be in test mode and see what happens. I am not sure when I will get a chance to do that, so stay tuned. Until then, perhaps the log files linked below will shed some light on this mystery...

Trying to share these from Google Drive since at least the one is too large to upload directly. Let me know if you have issues opening them.

Octoprint.log: https://drive.google.com/file/d/1sJT30gQppp_Jg54g4GJBNA7NLo58UGOk/view?usp=sharing
Plugin_Octolapse.log: https://drive.google.com/file/d/1gwm8TWea70uMizEIuqexKFmIUTuOMuhK/view?usp=sharing
serial.log: https://drive.google.com/file/d/1U16coBVqmBb8lrWnok_qXAlpg-4VYeZh/view?usp=sharing


#7

So I switched octolapse to full logging live print from test - no other changes, printed same GCODE as before, and no issues. The only thing to have changed was I tweked the Octolapse settings a bit because it was complaining that some settings were not unique. I hope it continues to work. I do keep getting an “out of print area” warning when it starts, but it seems to work fine. What can I do to make that stop?


#8

You'll have to adjust your build volume. Octolapse should report which position is out of bounds, then using that you can adjust the print volume to include that location. Look in the Octolapse Printer Profile and enable 'Override Octoprint Printer Volume' (or something similar). Note that X, Y and Z min can be negative in some printers (prusa mk2, mk3 etc..).

Let me know if you need any additional help to resolve that error!