My Mac can't resolve octopi.local


#1

Just got OctoPi set up, but am unable to reach it via the name octopi.local, only the IP. I am using macOS Sierra version 10.12.6, a Raspberry Pi 3 Model B, OctoPi image 2017-06-21-octopi-jessie-lite-0.14.0.img, and OctoPrint Version 1.3.6. Based on this FAQ, it seems like the name should just work. I'm only trying to access from home and I've also tried octopi.lan which doesn't work either. Any ideas? Thanks!


I can't reach my OctoPi under octopi.local
#2

Connected via Ethernet or WiFi?
What browsers you using or tried?
Can you connect to it thru the terminal?


#3

I am having the same issue. After just installing octoprint on my RP3 and going to http://octopi.local using both safari or chrome, I am not able to access OctoPrint from my browser. I am using a Mac and use both http or https just like instructed.


#4

I've also tried to access it via its IP address and no luck.


#5

If you can't even reach it via an IP address, something else is amiss. See this post:

If also added this to the original post for further troubleshooting.


#6

WiFi
Chrome, FireFox, and Safari
yes, but only using the IP

it seems to be a name resolution issue, but not sure how to resolve
"ping: cannot resolve octopi.local: Unknown host"


#7

Also try ping 192.168.1.20 or whatever you know the IP address to be. This will add it to your arp cache. I've seen this magically then work for name resolution.

If it were me, I would try to remote into the Pi using ssh and then run an ifconfig command to see what settings are being used for your connection. Here is the related portion from my own. The second line indicates the IP address, a correct netmask and broadcast address.

We see here that RX and TX errors are zero (I booted it about 30 minutes ago). We also see that there are a number of packets sent/received.

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.20.30.60  netmask 255.255.255.0  broadcast 10.20.30.255
        inet6 fe80::f263:3aec:cf10:4082  prefixlen 64  scopeid 0x20<link>
        inet6 2600:8801:9908:a200:17ea:82c4:c397:e962  prefixlen 64  scopeid 0x0<global>
        ether b8:27:eb:de:a7:c7  txqueuelen 1000  (Ethernet)
        RX packets 4204  bytes 1000602 (977.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4628  bytes 6239914 (5.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

#8

octopi.local is a manifestation of Bonjour (which should be running on a Mac). Find your DHCP server (usually your router), and use its web interface to see what name is associated with the IP address assigned to the Pi. If you use your router as your primary DNS server, then that name will resolve. In my case, octopi is all I need for a name (octopi.morgan.local if I wish to be formal about it :grin: )


#9

I'm running Octopi 0.14 on a 3B and octopi.local hostname resolution is working fine for me. It's a little slow connecting, but it does connect. I'm on a MacBook Pro running High Sierra beta, but I can also connect from my iPhone and iPad.


#10

If you're able to access OctoPrint via its IP address, make sure you didn't change the host name during setup. For instance I changed my host name to mk3, so I access via mk3.local
To check, ssh into your pi and run "sudo raspi-config". Goto hostname and check the name there.