I'm running 1.3.6, I get an update error when trying to update to 1.3.9+!

updating
octoprint-1-3-6

#1

OctoPrint 1.3.9 and later include a couple of dependency updates whose update during switch to 1.3.9 or later are known to trigger an "update failed" message within OctoPrint's update dialog:

image

The update did in fact succeed and the issue lies with a change in the underlying update mechanism concerning the dependencies. This problem has been fixed in 1.3.7/1.3.8 and versions prior to 1.3.6 aren't yet affected, so there you won't ever see this message.

If you are still running 1.3.6 though and updating from it, simply run the update a second time through Settings > Software Update > "Check for updates" and clicking "Update now" in the reshown update notification.


New release: 1.3.9