When I start a print bed and hotend doesn't heat before start


#1

Hey guys im using a Pi 3 B+ with octoprint on a cr-10 using logitech c270 webcam

I flashed octoprint for pi3b+ hooked everything up and followed a install guide off youtube

I was able to upload a couple of prints and everything seemed to work ok

I then installed 2 plugins Octolapse, and CR-10 bed level. Thats when my issues started

At that point I uploaded a sliced file from my computer and as soon as I hit the print button on the file instead of waiting to heat up the bed then the hot end it just instantly starts trying to print.

I was able to circumvent this by adding in gcode directly from my slicer settings onto the gcode page of octoprint but now my printer does this odd start up like its reading 2 start up gcodes and 2 sets of end gcode

I am not sure what I changed by installing these 2 plugins but I would like to fix it back to the way it was.

Has anyone experinced anything like this or know what the solution would be?

Not to add to the problems but ive been messing with octolapse all day and still cant get it to work either.


#2

First are you sure your G Code has adequate starting code that in fact waits for the heating up?

When unmounting the filament from the print head you can safely start a print without heat. Does octoprint send the corresponding commands to the printer (see the console log in the web interface)?

Otherwise I cannot confirm your behaviour. You could disable (temporarily) the plugins and retest while successively reenabeling the plugins. Then you might get the problem out.


#3

It's the same code ive always used. I will look at the log files of the failed print and see If I can post here. I'm almost positive it has something to do with the plugins I installed as it didn't do it until after those plugins.


#4

I'm having a similar issue,
I'm using a Pi 3 B+ with octoprint on a cr-10s using logitech c270 webcam.
The nozzle preheats as normal prior to bed level but the bed does not. The bed only starts to heat once the auto level has happened and only then about 5 seconds after print starts.
The only change I made was updating to Octopi 1.3.7


#5

People... you are really sabotaging yourselves here by not sharing any log files. OctoPrint has an application log and - in cases like these - you can also enable a very useful serial.log that will allow everyone to take a look at what goes over the line to your printer and figure out why things are not behaving well. There's a reason why there's a link to the FAQ entry where to find relevant log files on top of every post editor.

Don't make people willing to help you actively have to ask for this kind of information - this gets very frustrating after a while. Just provide it proactively.