Remote Pre-Printing Placement Sequence Extremely Slow


#1

What is the problem?
I recently installed octopi on my raspberry pi 3 B and, despite reviews I've come across, it was installed and working with little to no problem. I have a QIDI X-ONE-2 that I print on often, but I needed I wanted a remote solution so I can check/monitor prints on the go. However Whenever I try to start a print remotely (from the UI) the initial print sequence seems to go extremely slow and sporadic.

Usually when I start a print the manual way my test bed and extruder heat up, then the extruder moves to the top right corner of the test bed (beeps when hitting a bumper switch), then back to the bottom left corner of the test bed (beeps when hitting a bumper switch), and then the test bed rises to the extruder tip (beeps when hitting a bumper switch). I've seen this same sequence 100's of times, and it has never had an issue...

But when I try to start a print using the Octoprint UI with the Upload option (Upload to SD doesn't work for some reason), it loads the gcode with no problem, heats up the bed and the extruder to the correct temps (I double checked), but does this strange crawl with the extruder to the top right of the bed but never makes it, and then it starts doing a strange curve anti clockwise a bit... then jumps directly into the print with its normal speed while the print bed was never lifted to the correct position so filament just squeezes out of the extruder hanging in the air while moving to it's expected coordinates but printing in the air!

What did you already try to solve it?
1.) I tried this a few different times, only to see the same response.
2.) I tried manually moving the extruder around and everything seemed to be fine except for the Z axis moving in the reverse direction, but I went into the settings and corrected this. After that the controls worked fine.
3.) I tried printing that same file using the manual method (literally touching the printer screen), and it printed fine so I know it's definitely related to my setup.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Octoprint Version : 1.3.9
Printer : Qidi Tech X-ONE2 (Chinese Manufacturer - not sure if that effects coordinate translations)
Raspberry Pi 3 B
32GB Ultra San Disk (SD Card for raspberry pi)


#2

You might want to check your Settings -> Gcode Scripts for the one that occurs before the job prints. One of them should set the default movement speed.

Read me

Or visit your OctoPrint Settings -> Printer Profiles area and review again the speeds that you've set for your printer's motors.

Then open the Terminal tab and look at some of the commands that are sent. Look for a G1 ... Fnnnn command near the top. Those n's represent a number which indicates the movement speed.

A long time ago, I had incorrectly set my printer profile's maximum speeds and it would slooooowwwwwlllyyyy move during the initial startup but then behave once the sliced file started to be sent.


#3

There are a few lines with that. How do I know which one is associated to the settings on octoprint?


#4

After @OutsourcedGuru response (THANKS AGAIN!) That lead me down a rabbit hole of learning the correct terminology and commands, and I came across a great set of GCODE scripts that work AMAZINGLY with the Qidi X-One2. I figured I would share my findings in the case that someone else runs into the same issue:

;go to home position
G28 ; home all axes
G1 X0 Y0 Z10 F2400 ; bring extruder to front
G92 E0 ; zero the extruded length
G1 X160 F2400 ; Move head off to the right
G1 E19 F200 ; purge nozzle quickly
G1 X75 F4000 ; Move head to the center front of the bed
G1 Z0 F2000 ; bring head down to 0 height
G92 E0 ; zero the extruded length again

;After print job completes
G91 ; relative positioning
G1 E-1 F300
G1 Z+5 E-2 X-20 Y-20 F900
G90
G1 Z150 X0 Y150 F900
M104 S0 ;Turn off heaters
M140 S0 ;Turn off bed
M84 ; disable motors
M107 ; Turn off fans

;After print job is cancelled
G91 ; relative positioning
G1 E-1 F300

G1 Z+5 E-2 F2000
G90 ; Absolute positioning
G1 Z150 X0 Y150 F9000
M104 S0 ;Turn off heaters
M140 S0 ;Turn off bed

;After print job is paused
G91 ; relative positioning
G1 E-1 Z5 E-1 F1000
G90
G1 X0 Y0 F900
;Before print job is resumed
G91
G1 E15 F300
G1 Z-5 E5 F500
G90 ; Absolute positioning


#5

Well done.

6000 mm/min is OctoPrint's default but note that the firmware reports these values in mm/sec so always do the math when you're going back/forth between them.