Print Job auto-repeating and destroying completed print (printing from Cura plugin)


#1

Printer acts normally when octoprint is disconnected, but every print job sent through octoprint will immediately start over after completing. The progress bar on the octoprint frontend goes over 100%, see screenshot: https://imgur.com/gallery/1Re8PPj

Iv'e tried rebooting in safe mode. I'm really not sure what else to try becuase I can't thing of anything iv'e
changed recently besides updating a few plugins. The same problem happens when I connect to the virtual
printer port so I believe it's an octoprint problem not specific to my printer.

This is the serial log file for the virtual printer:
https://pastebin.com/vfXb5TCv

OctoPrint 1.3.9 running on OctoPi 0.15.1


#2

Hi @kendalf89!

In this thread, they also stumbled over this issue.


#3

Thanks for the quick response but I don't think I have the same problem. This is the file I've been testing with:
https://pastebin.com/vqkamnSR


#4

@kendalf89 Try it again in Safe Mode. If it works fine, then it's one of the plugins you added.

Can we confirm that you are not attempting to print directly to your printer via the Cura plugin?


#5

Because if you are printing directly to your printer via the Cura plugin, there is an updated version of the OctoPrint Connection plugin for Cura in the Marketplace that fixes this issue.


#6

Yes I am using the octoprint connection plugin in cura and I think that was the problem. It looked like I had the most recent version (3.5.3, 11/21/18) but I uninstalled it and reinstalled it just in case and it seems to have fixed the issue.