Pip version warning after successful plugin installation


#1

What is the problem?
After installing plugins getting warning about outdated pip version.

What did you already try to solve it?
Run apt-get update/upgrade and have all the latest updates installed.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

OctoPrint 1.3.10 running on OctoPi 0.15.1
Printer: Velleman Vertex K8400 converted into H-bot
Firmware: Klipper

Yesterday I discovered this video https://www.youtube.com/watch?v=Zq1sFBgxy8o by Teaching Tech and decided to install several plugins mentioned in this clip. While I did not have any issues with installation process itself, at the very end of installing each plugin I was getting the message

You are using pip version 9.0.3, however version 18.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

So, my question is - should I run the command
/home/pi/oprint/bin/python2 -m pip install https://github.com/malnvenshorn/OctoPrint-WebcamTab/archive/master.zip --no-cache-dir
as mentioned in plugin_pluginmanager_console.log, should I run any other command or just ignore this warning?

Thanks
Best regards,
Boris

octoprint.log (372.8 KB)
serial.log (6.5 KB)
plugin_pluginmanager_console.log (122.8 KB)


#2

Don't worry about this warning. PIP version 9 works just fine for OctoPrint.


#3

@fieldOfView Thanks! Good to know.


#4

@foosel You might consider adding the flag for pip install so that it stops doing this. I've seen a number of people taking it on their own to attempt to upgrade pip due to this message.

pip list --disable-pip-version-check

And again, today, we have another user trying to upgrade their pip.