Pip error while upgrading from 1.3.6 to 1.3.8


#1

When I try to upgrade from 1.3.6 to 1.3.8 I get the below error message:

error: Error -5 while decompressing data: incomplete or truncated stream
You are using pip version 8.1.1, however version 10.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

I updated & upgraded my raspbian software, I installed pip 10.0.1 (however octopi still claims I use 10.0.1), I enlarged my sd card space (in raspi-config)

Hope you can help me with this one... I'm out of options....

octoprint.log (67.7 KB)


#2

edit

Oh, sorry, that actual error message hid very well there:

error: Error -5 while decompressing data: incomplete or truncated stream

Taking a look into your log I see this:

IOError: [Errno 28] No space left o20

Looks like your SD card is full, which would definitely explain update errors of any kind. So I suggest you clear up your card and see if you can update then.


#3

Thanks for the quick reply!
When I check octopi.local i see enough space available, also Upgrade to pip 10.0.1 is done, but octopi claims I still use 8.1.1
Free%20memory
What do I do wrong or do i missed something?

Thanks in advance!!


#4

For the pip update, follow the FAQ entry that I linked. You probably upgraded the wrong pip, not the one that OctoPrint is actually using. But you can also just ignore that upgrade message, it's not relevant to the update succeeding or failing.

Regarding the space, based on your log you definitely had an issue there.

Best check manually. SSH into your machine, then:

df -h

That should give you the disk usage across all partitions:

pi@octopi:~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       7.4G  1.5G  5.6G  22% /
devtmpfs        434M     0  434M   0% /dev
tmpfs           438M     0  438M   0% /dev/shm
tmpfs           438M  6.0M  432M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           438M     0  438M   0% /sys/fs/cgroup
/dev/mmcblk0p1   43M   22M   21M  51% /boot
tmpfs            88M     0   88M   0% /run/user/1000

If you also have enough space according to that output, next step is to provide plugin_softwareupdate_console.log, maybe that contains more information.


#5

Hi,

Did as you requested, space is enough available, see added screenshot

Disk%20space

Checked also the log file, but I can't get anything out of that...
plugin_softwareupdate_console.log (252.7 KB)

Other option is to make a clean install with the latest available octopi download....

Thanks again!


#6

Hm... Looks like some general issue with uncompressing the archive, repeatedly. Got any network issues?

You could try if performing the update manually triggers the same problem:

/home/pi/oprint/bin/python -m pip install https://github.com/foosel/OctoPrint/archive/1.3.8.zip