Pi 3 model B unable to connect to WIFI


#2

I'm having the same issue. I even tried doing a headless install of just rasbian and got the same results. Once I installed Rasbian stretch with a GUI. the only way I was able to get on wifi was to set it up in the config wizard, but once I rebooted, I got the same results as you are.

Hopefully someone knows a fix!!


#3

What flavor of Raspberry do you have? I wonder if it is model specific? Another issue might be Chinese knockoffs of Raspberry. Mine was made in China, but i have run across references to them being mfg’ed in the UK.


#4

I'll have to look when i get home but its a 3 B+ Pi, as far as where its made, I'm not 100% sure.


#5

Also, when I was troubleshooting, I ran ifconfig and it there was no IP for wlan0, but when I plugged in an Ethernet cable I was able to get an IP for eth0.

Once I get the wifi configed within the GUI, pulling up Terminal and running ifconfig will show an IP for wlan0 but doing the regular set up (editing the wpa-supplicant in notepad++) I get no IP for wlan0.


#6

Just to be clear, you are editing /boot/octopi-wpa-supplicant.txt? The /boot partition is the only one visible if the SD card is mounted on the PC / Mac system where it was created with Etcher or the Mac equivalent.


#7

Yep, was editing it while it was in my computer and mounted. Then ejected the card, put it into my Pi and it would not connect to wifi. Once I plugged in my eth cable, it was able to get an IP and do all of the updates but still would not show an IP for wlan0.

The only way I was able to get wlan0 to get an IP was to install a GUI version of rasbian and do the config though the set up wizard. I tried to install Octoprint on top of the latest stretch build but I couldn't figure out certain parts of the walkthrough....I'm a noob when it comes to linux stuff.


#8

In response, yes. I was editing that file, and the screen shot in my post is of that portion of the file I edited. I have confirmed that my Raspberry can “see” my WIFI router (ATT Wireless) but dont know how to confirm that my raspberry is sending a handshake, or i there is another issue.


#9

One more question, is it a RPi3B or an RPi3B+?

My OctoPi (0.14.0, Jessie) on a RPi3B is connected via WiFi and attached to my 3D printer. I have an RPi3B+ with OctoPi 0.15.1 connected to my WiFi (but no printer). Both were successful connecting to WiFi on initial boot.

Do you have a monitor connected to the RPi? If not, how did you manage to get the sudo iwlist wlan0 scan output? Did you check the output of dmesg for clues?

You might have better luck looking / asking in the official RPi forums.

There are other threads in this Discourse on problems with WiFi connections but I don't know if any of them have any better suggestions.


#10

mine is a B +

I had it connected to a monitor and a keyboard which is how i was able to look up the IP on eth0.

I never ran that other command (sudo iwlist wlan0) I'll try that tonight and see if it can tell me anything else I couldn't find otherwise.

Is there a easy to follow walkthrough on how to install Octoprint on top of raspbian (with the GUI)? I can get raspbian up no problem, but some of the commands in the walkthrough on github were confusing.

Maybe I'll try and spin through them again tonight and try with a fresh set of eyes!


#11

To be clear, there are two of us with the same issue. For me, the boot partition was the only one visible. To answer a q that came up earlier, I had hooked the pi to a tv to see if it could see my router... Short answer is that it could see th3e router.
Today, after continuing to have problems we reflashed to octopi .13 We were able to log into another wifi network, but when I amended the txt file for the home router... No joy.


#12

Yea sorry to jump on your thread here as well, but it seems like we are having identical problems!!! Since you started the post, I'll just sit back and let you take over answering the questions! Hopefully I'll gain something from it as well!


#13

Everyone having problems in this thread should follow the instructions in the following thread.

Please note that the instructions are different depending on what version of OctoPi (a derivative of Raspbian-Lite, 0.14.0 = Jessie, 0.15.1 = Stretch) and what Raspberry Pi model (3B or 3B+). The RPi3B can run either Jessie or Stretch, the RPi3B+ must run Stretch (or later).

If you still have problems, make sure to provide the model of your Raspberry Pi, the version of OctoPi you installed, the OS and editor you used if you modified /boot/octopi-wpa-supplicant.txt before putting the SD card in the Raspberry Pi and if you tried (or can try) with an Ethernet cable connection.


#14

What works for me....
wifi won't work unless country is set properly

Move Country before your "network"
Reboot

country=AU # Australia

WPA/WPA2 secured

network={
ssid="youbetcha"
psk="lutefisk"
}

Cheers


#15

I had my pi 3B working on my home network, then moved it to my work network and had similar trouble. It turned out that the 2.4GHz band was full of noise. I was able to get a signal by moving the pi within 2m of the router, but it was fairly glitchy even then. The only answer was to use eth0 for reliable results. The noise is likely from a neighbor with a cheap webcam that is constantly filling the whole spectrum with garbage. After I got in the network I had to do some configuring through haproxy to get my webcam going. You may also want to check those settings of things still aren't working out.


#16

Do you have admin access to the router? You may can change the WiFi channel.
Or is the 2.4 GHz band completely polluted?


#17

Also had issues connecting to wifi on my RPi3B v1.2 (using img: 2018-04-18-octopi-stretch-lite-0.15.1)

I could find my access point fine with: sudo iwlist wlan0 scan it just didn't want to connect.

Moving the country code to before the "network" seemed to fix my issues strangely also (it was correctly configured)


#18

I've heard in several places now that people could not get connected to WiFi unless the moved the Country setting to come before their "network" section. Mine works just fine on a Pi 3B with the Country setting in the default location (near the end of the /boot/octopi-wpa-supplicant.txt file).

It's interesting to note that the older versions of OctoPi had the Country setting at the top of the /boot/octopi-wpa-supplicant.txt file (a lot of people never saw this in the older versions, since they used the octopi-network.txt file to set up their network).

Still, I'm not sure why it would matter. The settings in the octopi-wpa-supplicant.txt file are just linked to the wpa_supplicant.conf file in a directory on the other partition. The information is copied over on boot-up. I would not think the order it is listed in the /boot/ partition file would make a big difference. But then I'm no guru in how this actually happens.

If @foosel or @guysoft confirm that this could make a difference, I'll add a note to the WiFi troubleshooting guide.


#19

I solved my problem..... The issue, a bad wifi router. Finally in exasperation, I tried a different router, et voila problem was solved. Note that the firewall settings were identical,


#20

I note that if your wi-fi zone on your router is hidden then you need an extra line in your octopi-wpa-supplicant.txt file in the network section.

raspi-troubleshooter


One difference of the plus version of the Raspberry Pi 3B is that the main chip has a new metallic shield over it. In theory, the shield conducts heat better so that they could squeeze an additional 0.2GHz out of the top-end speed.

Next, the wifi chip was moved from the bottom of the board. The chip antenna is gone, now replaced with the PCB antenna design from the Raspberry Pi Zero W. They added 802.3az Energy Efficient Ethernet to the LAN device.

Analysis: Is it possible that the new plus version has shorter wi-fi range as a result of the many changes in this area?


#21

@rblum - If you have solved the problem, please check the little resolved icon in your post that describes the solution.