OctoPi WiFi/network connection troubleshooting megatopic

troubleshooting
wifi

#162

OH MY GOD! THANK YOU! THAT FIXED IT!!! I thought I'd have to wait days for a response ;-;;

Couple things the guide did differently (For those who run into this same problem in the future @hwurzburg ):

  • Download directly using "curl" through command prompt.

  • Install Bonjour.

  • Burn the .zip file directly, not the .img file inside. (This is actually a lot faster too!)

  • include "key_mgmt=WPA-PSK" in the octopi-wpa-supplicant.txt (I don't think this is what fixed it, but hey it's working :smiley:)


#163

@xKen The new problem is that some of these browsers or operating systems want to try to help you by automatically unzipping the download and end up tweaking something.

@foosel, @guysoft


#164

Windows is affected by not only the DHCP server's lease (if it's trying to find octopi.local) but it's also affected by its own arp cache, for what it's worth. The arp cache empties out after some amount of time which nobody knows other than the geek who wrote that document.

Somehow this feels more like a router-based problem than it does your Raspberry. If it were me, I'd wait until the problem shows up again (having put a keyboard/monitor/mouse on the Raspberry) and then run an ifconfig locally on the Pi to see if the wlan0 has its RUNNING flag.


#165

Greetings,

I am having an interesting problem with getting OctoPi to work with my Raspberry Pi 3. Before, I followed the exact steps of everything (flashing to a freshly wiped microSD card, editing the wpa file properly with Notepad++, putting in microSD card before using a wall outlet power supply to turn it on) and it worked instantly at school. However, now that I am home the octoprint is not showing up at all. I have changed the

  1. Changed the wpa text using Notepad++
  2. Wiped the microsd card and reflashed it
  3. Confirmed with my home internet that octoprint was indeed connected (still got nothing from the octoprint.local)
  4. Used a different microsd card
  5. Used an entirely different router that I had used and worked at school (still no good)
  6. Plugging in an HDMI does nothing (I assumed it was suppose to let me edit it/check that it works) so I don't think I can get diagnostic info atm...
  7. There is a solid red LED. A green led flashes every now and then (no pattern it seems)

So its my understanding that the raspberry pi is working and connected, but I can't access it from the outside. Very sad/annoyed because it was perfect the first time but now not working at all :confused: anyone have advice?


#166

Been struggling to get my pi 3 to connect through wifi, made changes to wpa_supplicant.conf as instructions said and didnt get it to work. got it working with some interface changes, but suddenly stopped working.
Decided to start over, and thist time didnt change anything in wpa_supplicant.conf, i just used raspi-config to change localisation settings, and then it allowed me to change wifi settings and wifi started working instantly.


#167

Rewind this thread to this post and try those instructions.