I'm running 1.2.7, I tried to update to a newer version via the software update plugin but I'm still on 1.2.7 after restart!

updating
octoprint-1-2-7

#1

There is a bug in 1.2.7 that prevents updating OctoPrint. It still detects that there's a new version available but upon trying to apply it all you get is a "update successful" message without anything actually happening. This bug is fixed in version 1.2.8 of OctoPrint and a plugin is provided for people running 1.2.7 that monkey patches the fix into 1.2.7 as well so an update via the software update plugin is possible.

Please see the release notes of 1.2.8 and specifically the section "A bug in 1.2.7 prevents directly updating to 1.2.8, here's what to do" for how to proceed.


OctoPrint tells me I have an update available but I can't apply it