I see a lot of "communication timeout" messages in the log

general
serial

#1

Your printer is taking a bit too long to respond and so OctoPrint assumes it has gone AWOL and tries to tickle it back into replying.

Current firmware versions should support the busy protocol and hence produce busy:processing messages during long operations, solving this problem. So a firmware update that enables busy protocol support for your printer would be the best solution here.

If that is not an option, you'll have to increase your timeout values in OctoPrint. Open your Settings page and in the "Serial Connection" section modify the value for "Communication Timeout":