Firmware Updater " Flashing failed! Timeout communicating with programmer"


#1

Until today I flashed skynet software changes using sloeber and the USB port of the Anet A8 mainboard.

Today I tried to flash the firmware of my Anet A8 using the Octopi "Firmware Updater".
Until now it does not work, because after a view seconds the message

"Flashing failed. Timeout communicating with programmer"

appears.

avrdude is installed correctly. The Firmware Updater Plugin is installed and configured.

image

I am using octoprint version 1.3.9, skynet version 2.3.2 on an Anet A8 Printer.

Maybe someone can give me a hint, what's wrong.


#2

You might want to see if the Advanced Settings allows you to control the serial baud rate. I think I would check to make sure that everything is the same as you've done before. (Did you have to push the printer's board's RESET button in the past?)

You say that before now, you haven't used OctoPrint/Firmware Updater to do this and you were successful. And now (maybe this is the first time), you can't get this to work within the plugin. Hopefully I understand what you're saying. What baud rate did you use before with sloeber?


#3

The plugin must have exclusive access to the USB port. OctoPrint must be in "disconnect" connection state from the printer. You can't have the plugin and OctoPrint at the same time using the USB port.


#4

I wonder why the plugin author doesn't disconnect, upload, connect as part of the process, then?


#5

With direct connection from my PC to the Anet Mainboard via USB it worked correctly.
The baudrate I used with sloeber was 115200.
I used the same with octopi.
--> Same Error!

I disconnected octoprint from the Anet, before starting to flash.
--> Same Error!

I pressed the reset Button on the Anet Board and tried to flash again.
--> Same Error!

I also changed the configuration of the Plugin to an m1284p as stated by sloeber.
--> Same Error!

Then I connected the Anet Mainboard to my PC and flashed directly using sloeber.
As you can see in the output of sloeber, it worked.

So I'am a bit confused.

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e9705 (probably m1284p)
avrdude: reading input file "D:\77_Development\Arduino\Code\Skynet/Release/Skynet.hex"
avrdude: writing flash (116932 bytes):

Writing | ################################################## | 100% 26.59s

avrdude: 116932 bytes of flash written
avrdude: verifying flash memory against D:\77_Development\Arduino\Code\Skynet/Release/Skynet.hex:
avrdude: load data flash data from input file D:\77_Development\Arduino\Code\Skynet/Release/Skynet.hex:
avrdude: input file D:\77_Development\Arduino\Code\Skynet/Release/Skynet.hex contains 116932 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 22.25s

avrdude: verifying ...
avrdude: 116932 bytes of flash verified

avrdude done. Thank you.


#6

When I see things like this... I have to shake my head. The first half of the path is Windows-based (with backslashes) and the remainder of the path is UNIX-based (with forward slashes).

Anyway, take @flavict's advice.

  1. Attach the serial cable back to your Raspberry Pi that's running OctoPrint and confirm that it can CONNECT
  2. Now within the OctoPrint interface expand that side panel for Connection and then press the DISCONNECT button
  3. Now attempt to visit Settings -> Firmware Updater and see if it will work