ERROR: tornado.access - WARNING - 404 GET /currentsetting.htm


#1

I am still new to Octopi, but I have been using enough to fall in love with it. I just learned about logs and I am getting the included warning repeatedly with new times every few minutes. Any help would be appreciated. Again, I have only used it a few days at this point. OctoPrint 1.3.6 running on OctoPi 0.14. gcode cut with Cura 3.2.1 on PC then uploaded to Octopi

2018-03-18 17:08:45,120 - tornado.access - WARNING - 404 GET /currentsetting.htm (127.0.0.1) 11.41ms


#2

Something in your network for some reason is trying to access a currentsetting.htm on OctoPrint's server, which doesn't exist.

You can just ignore that (it's basically OctoPrint logging a "wrong number, sorry!" for a request it received), but you might want to figure out what is throwing these senseless requests against OctoPrint.


For those reading this and wondering why I said "somewhere on your network" when it says 127.0.0.1 as originating address there - OP stated they are running octopi, that ships with haproxy in front, which will make requests like this seem to originate from localhost even if they come from somewhere else.

#3

This appears to be from Netgear's Genie network map.


#4

Great pieces of information. I do run a Netgear AC1900 with Netgear Genie. Maybe I will re route my pi through my switch instead. Thank you. Octopi is awesome!


#5

Just for the record:

Also, would be great if you'd mark the answer from @tedder42 as solution so it can be found easier :slight_smile: